March, 2026
Incident Updates
Wednesday, March 4th
No Incidents
Thursday, March 5th
No Incidents
Friday, March 6th
Maintenance Completed
Planned Maintenance for ML Models
Saturday, March 7th
No Incidents
Sunday, March 8th
No Incidents
Monday, March 9th
RESOLVED
Maverick DOWN
Tuesday, March 10th
No Incidents
Wednesday, March 11th
No Incidents
Thursday, March 12th
No Incidents
Friday, March 13th
No Incidents
Saturday, March 14th
INVESTIGATING
Disruption Caused by Internal Infrastructure Downtime
INVESTIGATING
GLM 4.6 DOWN
RESOLVED
Maverick DOWN
RESOLVED
GPT-OSS DOWN
RESOLVED
GPT-OSS DOWN
RESOLVED
Maverick DOWN
RESOLVED
Kimi-K2.5 DOWN
RESOLVED
Kimi-K2.5 DOWN
RESOLVED
GPT-OSS DOWN
RESOLVED
Maverick DOWN
RESOLVED
GPT-OSS DOWN
Sunday, March 15th
RESOLVED
Maverick DOWN
RESOLVED
GPT-OSS DOWN
RESOLVED
Maverick DOWN
RESOLVED
Maverick DOWN
RESOLVED
GPT-OSS DOWN
RESOLVED
GPT-OSS DOWN
Monday, March 16th
RESOLVED
Kimi-K2.5 DOWN
Tuesday, March 17th
No Incidents
Wednesday, March 18th
RESOLVED
Maverick DOWN
Thursday, March 19th
RESOLVED
Maverick DOWN
Friday, March 20th
No Incidents
Saturday, March 21st
No Incidents
Monday, March 23rd
No Incidents
Tuesday, March 24th
No Incidents
Wednesday, March 25th
RESOLVED
Maverick DOWN
Thursday, March 26th
RESOLVED
GPT-OSS DOWN
Friday, March 27th
No Incidents
Saturday, March 28th
No Incidents