June, 2026
Incident Updates
Tuesday, June 2nd
No Incidents
Wednesday, June 3rd
No Incidents
Thursday, June 4th
RESOLVED
Kimi-K2.5 DOWN
Friday, June 5th
No Incidents
Saturday, June 6th
No Incidents
Wednesday, June 24th
No Incidents
Thursday, June 25th
No Incidents
Friday, June 26th
RESOLVED
API DOWN
RESOLVED
Dashboard DOWN
RESOLVED
Homepage DOWN
RESOLVED
Kimi-K2.5 DOWN
RESOLVED
GPT-OSS DOWN
RESOLVED
Maverick DOWN
Saturday, June 27th
No Incidents
Sunday, June 28th
No Incidents
Monday, June 29th
Maintenance Completed
Scheduled Maintenance on relaxAI Service
Tuesday, June 30th
No Incidents
Wednesday, July 1st
No Incidents